Windows Azure Trust Center

Windows Azure Trust Center was released to the public and it contains valuable information about security and privacy on the platform. You can find details about what kind of certificates the platform holds and generally why and how the platform is secure, handles data and respects privacy. All that information applies to Windows Azure core services which are Compute, Storage and Virtual Network.

Currently the platform is audited and it has certificates for:

  1. ISO 27001
  2. EU Model Clauses and Data Processing Agreement
  3. SSAE 16 (SOC 1 Type 2)

For more information and details please visit the Windows Azure Trust Center here.

Thank you,

PK.

Windows Azure MVP 2012 – Renewed

I received my renewal email today from the MVP Award program. I’m going to be a Windows Azure MVP for a second year in a total of 3 years being an MVP.

I’m still proud to be on the first wave of Windows Azure MVPs when the MVP award was available for Windows Azure. I met a lot of those people at the MVP Summit and I’m glad I’m back for another year.

Cu around in an event, online on a forum, blog etc.

Cheers,

PK.

Failed to attach debugger on Windows Azure Web apps troubleshoot

There is a common error sometimes when you try to start and debug a web site/web app on the Windows Azure Emulator that it’s caused for a couple of reasons that I will explain below. The error message is “There was an error attaching the debuger to the IIS worker process for URL <THE_URL> …”.

Reason 1

You’re trying to run a 32bit application on a 64bit machine, so the application pool on IIS also 64 bit, without having the Enable32BitApps flag on the application pool enabled. That will cause the application not to start at all and of course the debugger will fail to attach to the IIS process and you’ll get this message.

Solution

Enable the flag on the application pool. To do so, Open IIS Manager, go to the Application Pools, select the pool and then from the menu panel on the right, select “Advanced Settings”. There is an option “Enable 32-bit Applications”, set that to True.

Reason 2

It could be multiple other reasons under this rule that all sum up to “Your application doesn’t run correctly on IIS 7.5″. It might be configuration issues, it might be authentication issues, it might be anything that makes your web app fail to run properly on IIS 7.5. If you have such errors and you try to deploy the web app to the Windows Azure Compute Emulator then of course the website won’t start as it’s hosted under IIS 7.5 and the debugger will fail to attach to it.

Solution

Check if your website works “normaly” under IIS 7.5. Create a new WebSite that points to the application directory and see if it works properly when it runs under IIS 7.5. If it works there then it’s going to work on the Compute emulator as well.

Reason 3

This is very rare but it might happen so I just include it here. For some very rare conditions it might be that when you upgrade your Windows Azure SDK that, specially the old versions (1.3 and 1.4), there are some left overs of configuration on your machine. Those could be registry keys and environment variables.

Solution

Finding the registry keys it’s not easy. It might sound crazy but your only shoot at this is using ProcMon.exe from Sysinternals and see what kind of keys the emulator tries to access before it fails. As for environment variables, on Windows 7 you just have to go to “Computer”, right click open Properties then “Advanced System Settings” from the panel on the left and lastly “Environment Variables..”. Make sure you don’t have “fixed” machine wide environment variables which are like Rd* (RdRoleID, RdRoleRoot etc). This solution also works when the SDK “misbehaves” and the RoleEnvironment class properties don’t work correct locally, among other things. After deleting those, you’ll need a full system restart.

Hope it helps,

PK.

Go to top